Startseite
Amiforce 2.1     Amiforce-News Amiforce-News Amiforce-Forum Amiforce-Forum Amiforce-Chat/IRC-Chat Amiforce-Chat/IRC-Chat Gästebuch Gästebuch Kontakt mit dem Webmaster aufnehmen Kontakt mit dem Webmaster aufnehmen

Amiblitz3
Amiblitz2(alt)
Storm Wizard
Abakus-Design
Helpguide
Toolsguide
Tipps&Tricks
Gamesfun
Links
Download
Musik

Bugfixes am Forum
Subdomains aktiviert
Counterscript entfernt
  Navigation:   Index / 
Amiforce Forum - Debugger verursach GRIM auf X1000
Registrierung Häufig gestellte Fragen Suche Mitgliederliste Moderatoren und Administratoren Startseite Bugtracker Chat Irc
Amiforce Forum » AmiBlitz2/3 (Archiv) » Debugger verursach GRIM auf X1000 » Hallo Gast [registrieren|anmelden]
« Vorheriges Thema | Nächstes Thema » Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Neues Thema erstellen Antwort erstellen
Autor
Beitrag [  «    1  2  ]
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

was mir unter Upd6 aufgefallen ist, das der Debugger nun öffter abschmirt und auch die Offsets im .dbg-file nicht einen verwertbaren Offset mehr bringen...

09.03.2013, 16:45  
Tomsmart1
König



Dabei seit: August 2007
Herkunft:
Beiträge: 751
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von Tomsmart1 suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

@Blackbird

macht es einen unterschied ob du mit oder ohne Debugger(informationen) kompliliert hast?


__________________
mfg
Thomas

09.03.2013, 20:59 Tomsmart1 ist offline   Profil von Tomsmart1 Füge Tomsmart1 deiner Freunde-Liste hinzu
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Gute Frage !

Muß ich morgen mal testen wenn ich noch dazu komme. Bin die nächste Woche bis Mittwoch wieder in der Schweiz...

09.03.2013, 21:02  
Tomsmart1
König



Dabei seit: August 2007
Herkunft:
Beiträge: 751
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von Tomsmart1 suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Zitat:
Original von Blackbird
Gute Frage !

Muß ich morgen mal testen wenn ich noch dazu komme. Bin die nächste Woche bis Mittwoch wieder in der Schweiz...



So schlecht ist die Schweiz auch nicht , mach das beste daraus


__________________
mfg
Thomas

09.03.2013, 21:10 Tomsmart1 ist offline   Profil von Tomsmart1 Füge Tomsmart1 deiner Freunde-Liste hinzu
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Freilich ist die Schweiz nicht schlimm, ist halt ne Weiterbildung....

Hoffentlich vergehen die Tage schnell damit ich dann weitermachen kann am Source

Aber ich nehme meinen Laptop mit, dann kann ich abends wenigstens mal hier reinschauen und sehen was ihr hier so treibt

09.03.2013, 21:28  
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Also es macht keinerlei unterschied, die Offsets bringen keinen Treffer in der dbg.datei

Ich habe PfP z.B erst mit dbg.file kompiliert damit alles passt. Dann nochmal ohne... Dann einen sicheren Crash verursacht aber keine Offsets passen oder zeigen auf die Stelle (weil ich weis woran es liegt...

10.03.2013, 10:27  
Tomsmart1
König



Dabei seit: August 2007
Herkunft:
Beiträge: 751
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von Tomsmart1 suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Zitat:
Original von Blackbird
Also es macht keinerlei unterschied, die Offsets bringen keinen Treffer in der dbg.datei

Ich habe PfP z.B erst mit dbg.file kompiliert damit alles passt. Dann nochmal ohne... Dann einen sicheren Crash verursacht aber keine Offsets passen oder zeigen auf die Stelle (weil ich weis woran es liegt...



Ich meine nicht das erstellen des .dbg Files sondern ob der "Runtime Error Debugger" aktiviert war bei der Erstellung der Exe,. Entweder über das Menü "Kompilier" mit Haken vor "Debug-Code erzeugen" bzw in den Kompilereinstellungen mit dem Haken vor "Runtime Error Debugger".
Da wenn dieser aktiviert ist der Kompiler Zusatzinformationen in das Executable einfügt für den Debugger.


__________________
mfg
Thomas

11.03.2013, 11:56 Tomsmart1 ist offline   Profil von Tomsmart1 Füge Tomsmart1 deiner Freunde-Liste hinzu
Der_Wanderer
Foren Gott




Dabei seit: März 2006
Herkunft: Karlsruhe, Baden-Württemberg
Beiträge: 3564
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von Der_Wanderer suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Für die .dbg File ist es egal, ob Debugger Info an ist oder nicht. Die ist dazu da, wenn Segtracker (oder OS4) einen Stacktrace rausgibt, das auf die Sourcecode Zeile zurückzuführen wo der Crash aufgetreten ist.

Wenn es keine verwertbare Addresse gibt, dann wurde der Stack getrashed.
Passiert leider häufiger als man denkt...


__________________
Check out http://www.hd-rec.de !

Dieser Beitrag wurde von Der_Wanderer am 11.03.2013, 15:42 Uhr editiert.

11.03.2013, 15:42 Der_Wanderer ist offline   Profil von Der_Wanderer Füge Der_Wanderer deiner Freunde-Liste hinzu Email an Der_Wanderer senden Homepage von Der_Wanderer
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Ich kompiliere nie ein exe mit Debugger an !

Stack muß ich überprüfen wenn ich wieder daheim bin...
Sollte eigentlich aber auf 400k oder gar 600k sein

11.03.2013, 17:50  
[  «    1  2  ]   « Vorheriges Thema | Nächstes Thema »
Neues Thema erstellen Antwort erstellen
Gehe zu: