Startseite
Amiforce 2.1     Amiforce-News Amiforce-News Amiforce-Forum Amiforce-Forum Amiforce-Chat/IRC-Chat Amiforce-Chat/IRC-Chat Gästebuch Gästebuch Kontakt mit dem Webmaster aufnehmen Kontakt mit dem Webmaster aufnehmen

Amiblitz3
Amiblitz2(alt)
Storm Wizard
Abakus-Design
Helpguide
Toolsguide
Tipps&Tricks
Gamesfun
Links
Download
Musik

Bugfixes am Forum
Subdomains aktiviert
Counterscript entfernt
  Navigation:   Index / 
Amiforce Forum - gr. Bildschirmaufl. unter e-uae/Linux/Amigaforever
Registrierung Häufig gestellte Fragen Suche Mitgliederliste Moderatoren und Administratoren Startseite Bugtracker Chat Irc
Amiforce Forum » Amiga Emulation » gr. Bildschirmaufl. unter e-uae/Linux/Amigaforever » Hallo Gast [registrieren|anmelden]
« Vorheriges Thema | Nächstes Thema » Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Neues Thema erstellen Antwort erstellen
Autor
Beitrag
gerograph
Doppel-As



Dabei seit: Mai 2010
Herkunft:
Beiträge: 105
  gr. Bildschirmaufl. unter e-uae/Linux/AmigaforeverAntwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von gerograph suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Vielleicht weiß ja hier einer Rat, da Ihr anscheinend häufig mit UAE arbeitet. Zumal der "picasso96fix" anscheinend aus der Blitz Ecke kommt...

Folgendes Problem:
Unter KXLight (minamles Knoppix Linux, welches dann e-uae startet - auf Platte installiert von der neuen AmigaForever Plus) bekomme ich keine Bildschirmauflösung größer 1024x768 hin....

Unter Knoppix/X11 ist anscheinend eine Bildschirmauflösung von 1280x800 (und div. weitere) möglich. Dazu habe ich in der xorg.conf entsprechende "Modelines" und in der Screenssection die Auflösungen und Farbtiefen definiert. D.h. wenn dann UAE gestartet wird habe ich schwarze Ränder an der Seite (UAE/AOS arbeitet ja nur mit 1024 x 76. Sobald ich die WB mit der Maus verlasse sehe ich den typischen "X" X11 Mauszeiger. Also Linuxseitig funktionierts...

Installation von KXLight/UAE auf Festplatte erforderte diverse Änderungen in der hd_boot.uaerc, u.a. die Bildschirmauflösung:

code:

# E-UAE configuration file

# General options
unix.rom_path=/Shared/rom
unix.floppy_path=
use_gui=false
use_debugger=false

# Host CPU-specific options
x86.use_tsc=true

# CPU emulation options
cpu_type=68020/68881
cpu_speed=max
cpu_compatible=false
cpu_cycle_exact=false

# JIT compiler options
cachesize=16384
compfpu=true

# Chipset options
chipset=ecs_agnus
ntsc=false
immediate_blits=true
collision_level=none

# ROM options
kickstart_rom_file=$(FILE_PATH)/amiga-os-3x0.rom
kickstart_key_file=$(FILE_PATH)/rom.key
kickshifter=false

# RAM options
chipmem_size=4
bogomem_size=0
fastmem_size=0
z3mem_size=128
gfxcard_size=32

# Floppy drive options
floppy0=
floppy0type=0
floppy1=
floppy1type=0
floppy2=
floppy2type=0
floppy3=
floppy3type=0
nr_floppies=4
floppy_speed=100

# Hard disk options
filesystem2=rw,DH2aten:/media/sda1/System,1
filesystem2=rw,DH3:WorkX:/media/sda1/Work,0
filesystem2=rw,DH1:Work:/Shared/dir/Work,0
#filesystem2=rw,DH0:Workbench:/Shared/dir/Workbench,0

# Display options
gfx_framerate=1
gfx_width_windowed=1280
gfx_height_windowed=800
gfx_width_fullscreen=1280
gfx_height_fullscreen=800
gfx_fullscreen_amiga=true
gfx_lores=false
gfx_linemode=double
gfx_correct_aspect=false
gfx_center_horizontal=none
gfx_center_vertical=none
show_leds=false

# Sound options
sound_output=normal
sound_bits=16
sound_frequency=44100
sound_channels=stereo
sound_interpol=none

# Input device options
joyport0=mouse
joyport1=kbd1

# SCSI emulation options
scsi=true
scsi_device=/dev/cdrom

# Network emulation
bsdsocket_emu=true

# X11-specific options
x11.map_raw_keys=false
x11.low_bandwidth=false
x11.use_mitshm=true



Was immer ich mache in den Screenprefs sehe ich maximal eine Auflösung von 1024x768x16, keine Auflösung wird in 32 Bit gelistet ?? So dass habe ich alles schon probiert:

- Standard Amigaforever WB31 Installation
- nutzen des picasso96fix aus dem WinUAE 1.000 Paket
- zustätzlich rtg.library aus dem selben Paket
- Frische AOS 3.9 Installation incl. Picasso von selbiger CD
- ersetzen der rtg.library durch die neueste Version aus dem WinUAE Paket 2.20 (war glaub ich die Version)
- einen picasso96fix gibts da nicht mehr, obwohl in der readme noch erwähnt. Dennoch zustätzlich mal mit dem fix getestet
- Screenmode Defintions Tool (PicassoMode oder wie sich das nannte..) probiert, aber dort sagt er immer, die GraKa unterstützt den definierten Mode nicht...
- picasso96fix natürlich immer direkt vor "loadwb" inder ss aufgerufen (ohne "run")

Warum geht das nicht ? Warum bekomme ich keine 32 bit Screenmodes ? Jemand ne Idee ???

Gruß Gero









28.01.2011, 19:51 gerograph ist offline   Profil von gerograph Füge gerograph deiner Freunde-Liste hinzu
Der_Wanderer
Foren Gott




Dabei seit: März 2006
Herkunft: Karlsruhe, Baden-Württemberg
Beiträge: 3564
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von Der_Wanderer suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Schwer zu sagen, unter WinUAE habe ich 1920x1600x32 am laufen.
Grundsätzlich würde ich sagen, RTG RAM ist zu wenig, aber in deiner Konfig hast du 32MB, das sollte langen, vor allem kleinere Screens sollten in 32bit gehen.

Das scheint eher ein Problem vom Linux UAE zu sein als von der AmigaOS install.


__________________
Check out http://www.hd-rec.de !

31.01.2011, 13:47 Der_Wanderer ist offline   Profil von Der_Wanderer Füge Der_Wanderer deiner Freunde-Liste hinzu Email an Der_Wanderer senden Homepage von Der_Wanderer
gerograph
Doppel-As



Dabei seit: Mai 2010
Herkunft:
Beiträge: 105
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von gerograph suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Das 32 Bit Problem ist gelöst... dazu muß man in der xorg.conf als default 24bit einstellen, dann sind 32bit Modi verfügbar, aber mehr als 1024x768 bekomme ich nicht hin, obwohl X-Windows die Bildschirmauflösung drauf hat. Liegt vielleicht am e-uae...

Gruß Gero

31.01.2011, 19:34 gerograph ist offline   Profil von gerograph Füge gerograph deiner Freunde-Liste hinzu
bruZard
König



Dabei seit: August 2005
Herkunft:
Beiträge: 830
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von bruZard suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Mein e-uae läuft in 1920x1080, daran kann es also nicht liegen.


__________________
PanzerZ | jBB / HTML5 Canvas Framework

01.02.2011, 08:35 bruZard ist offline   Profil von bruZard Füge bruZard deiner Freunde-Liste hinzu Homepage von bruZard
gerograph
Doppel-As



Dabei seit: Mai 2010
Herkunft:
Beiträge: 105
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von gerograph suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

O.k. Danke für die Infos... komisch, glaub ich muß doch mal Cloanto mailen....

Warum hat Cloanto eigentlich Knoppix als Grundlage fürs E-uae genommen ? Wäre es nicht möglich eine aktuelle schnellbootende Linuxdistro mit vernünftiger HW Unterstützung zu nehmen (z.B. Damn Small Linux oder sowas) ? Weil direkt ins AmigaOS booten auf meinem Laptop hat schon was...
(gab ja mal so ein Projekt auf Gentoo basierend, glaub ich....)
Aber ich hab absolut keine Ahnung von Linux, sonst hätte ich es mal getestet.

02.02.2011, 17:26 gerograph ist offline   Profil von gerograph Füge gerograph deiner Freunde-Liste hinzu
  « Vorheriges Thema | Nächstes Thema »
Neues Thema erstellen Antwort erstellen
Gehe zu: