Startseite
Amiforce 2.1     Amiforce-News Amiforce-News Amiforce-Forum Amiforce-Forum Amiforce-Chat/IRC-Chat Amiforce-Chat/IRC-Chat Gästebuch Gästebuch Kontakt mit dem Webmaster aufnehmen Kontakt mit dem Webmaster aufnehmen

Amiblitz3
Amiblitz2(alt)
Storm Wizard
Abakus-Design
Helpguide
Toolsguide
Tipps&Tricks
Gamesfun
Links
Download
Musik

Bugfixes am Forum
Subdomains aktiviert
Counterscript entfernt
  Navigation:   Index / 
Amiforce Forum - AmiBlitz3 Development Thread
Registrierung Häufig gestellte Fragen Suche Mitgliederliste Moderatoren und Administratoren Startseite Bugtracker Chat Irc
Amiforce Forum » AmiBlitz2/3 (Archiv) » AmiBlitz3 Development Thread » Hallo Gast [registrieren|anmelden]
« Vorheriges Thema | Nächstes Thema » Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Neues Thema erstellen Antwort erstellen
Autor
Beitrag [  «    ...  37  38  39  40  41  ]
Der_Wanderer
Foren Gott




Dabei seit: März 2006
Herkunft: Karlsruhe, Baden-Württemberg
Beiträge: 3564
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von Der_Wanderer suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

In naher Zukunft ist ein stabiles Release geplant.

Von meiner Seite aus gibt es sonst keine Verbesserungswünsche. Momentan liegt meine Konzentration auf anderen Projekten wie NTUI und A/A++.


__________________
Check out http://www.hd-rec.de !

22.12.2010, 14:47 Der_Wanderer ist offline   Profil von Der_Wanderer Füge Der_Wanderer deiner Freunde-Liste hinzu Email an Der_Wanderer senden Homepage von Der_Wanderer
Tomsmart1
König



Dabei seit: August 2007
Herkunft:
Beiträge: 751
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von Tomsmart1 suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Zitat:
Original von Der_Wanderer
Alle Zeichen zwischen 128 und 255 ersetze ich durch ???.
Das liegt daran, dass der Clipboard Code dann manchmal hängt. Wir können es aber auch wieder auskommmentieren, und schauen ob es trotzdem stabil ist.

Die Datei im RAM ist nur zu debug zwecken. Die kann ich auch rausmachen, sorry.

JA ich denke das wäre besser, da können wir ja nochmal intensiv testen.

Zitat:
Original von Der_Wanderer
Die dos.inlcude geht bei mir. Ich mache mal ein kleines Demo.


Das wäre nett, vielleicht mach ich einfach was falsch.


__________________
mfg
Thomas

25.12.2010, 14:13 Tomsmart1 ist offline   Profil von Tomsmart1 Füge Tomsmart1 deiner Freunde-Liste hinzu
mrodfr
Routinier




Dabei seit: Oktober 2006
Herkunft: france
Beiträge: 273
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von mrodfr suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Hello,

Problems found with Amiblitz3 last version SVN on classic:

Help key:
--------
Window : work
Window: not work
Window : work


source code window:
------------------
- You load a sourcecode.
- You put the cursor on the place you want.
- you mark with the LMB another place of the source for a cut'n'paste.

The cursor not jump automatically on the first caracter marked by the previous cut'n'paste.

search and replace window:
-------------------------
- You have allready searched something (you have allready an entry).
- You cut the nexts earch on the sourcecode window.
- you open the search and replace window.
- you mark with the LMB the search case and use Amiga+V for paste.

one caracter from the previous search is allways here.

Rendering problem:
-----------------
- open a new source window
- copy this line

GTListView #FX,1,0,0,*wFX\Width-*wFX\BorderRight-*wFX\BorderLeft,*wFX\Height-*wFX\BorderTop,"",0,outils()

- go to outils() with the cursor.
- now go back to GTlistview with the left arrow key.

The result is GTlistview not well rendered (or not completely bold).


Instruction brwoser rendering problem:
-------------------------------------
- you search something
- you decrease or increase horizontally a little the instruction browser window.
- you do things on the main instruction browser listview (vertical scrolling or click a line).

The result is some garbage on the window. The new dimension size of the instruction brwoser not used.


Blitzlibs on compiler settings:
------------------------------
For example, you have source with blitzlibs: on compiler or sources who include otheres sources with blitzlibs: on compiler.

Here when compiling the sources, guru related to ram 44.23
or the guru arrive when you quit amiblitz3.


another example: you have two source loaded and jump from the first to the second.

IMHO, this problem arrive after compiling one time with debugger enabled.


This is my last guru on the classic, see the "RAM" for the guru I talk on this post.

============================================================
Date : jeudi 23-déc-10 09:29:12
Task : 44F4FF48 "Blitz3ebug/REDDebugger"
Error : 8000002B (DEADEND)
By : System: no alert occured
Cause : Uninitialized TRAP #B vector
-----------------------------------------------------------
Date : jeudi 23-déc-10 12:50:03
Task : 443A5CD0 "RAM"
Error : 0100000C (Recoverable)
By : ExecLibrary
Cause : Sanity check on memory list failed during AvailMem(MEMF_LARGEST)
-----------------------------------------------------------
Date : dimanche 26-déc-10 06:41:32
Task : 4511EA60 "Blitz ][ Program Proc"
Error : 80000004 (DEADEND)
By : System: no alert occured
Cause : Illegal instruction
-----------------------------------------------------------
Date : dimanche 26-déc-10 06:44:00
Task : 4511E780 "Blitz ][ Program Proc"
Error : 80000003 (DEADEND)
By : System: no alert occured
Cause : Illegal address access (ie: odd)
----------------------------------------------------------
Date : dimanche 26-déc-10 06:44:29
Task : 4511E780 "Blitz ][ Program Proc"
Error : 8000000B (DEADEND)
By : System: no alert occured
Cause : Line 1111 Emulator error
-----------------------------------------------------------
Date : lundi 27-déc-10 07:15:06
Task : 443A5E50 "RAM"
Error : 0100000C (Recoverable)
By : ExecLibrary
Cause : Sanity check on memory list failed during AvailMem(MEMF_LARGEST)
-----------------------------------------------------------
Date : jeudi 30-déc-10 09:44:19
Task : 443A6298 "RAM"
Error : 0100000C (Recoverable)
By : ExecLibrary
Cause : Sanity check on memory list failed during AvailMem(MEMF_LARGEST)
-----------------------------------------------------------
Date : vendredi 31-déc-10 11:22:08
Task : 443A6298 "RAM"
Error : 0100000C (Recoverable)
By : ExecLibrary
Cause : Sanity check on memory list failed during AvailMem(MEMF_LARGEST)
-----------------------------------------------------------


Hey, just remember the bugtracker. allways actuality or now bugs are entered on SVN directly ?


Addon 01 January RAM guru problem:

-----------------------------------------------------------
Date : samedi 01-jan-11 08:45:02
Task : 443A5CD0 "RAM"
Error : 0100000C (Recoverable)
By : ExecLibrary
Cause : Sanity check on memory list failed during AvailMem(MEMF_LARGEST)
-----------------------------------------------------------
Date : Saturday 01-Jan-11 08:45:52
Task : 443A5CD0 "Unknown"
Error : 87000004 (DEADEND)
By : DosLibrary
Cause : Unexpected packet received
-----------------------------------------------------------
Date : samedi 01-jan-11 09:14:57
Task : 443A6418 "RAM"
Error : 0100000C (Recoverable)
By : ExecLibrary
Cause : Sanity check on memory list failed during AvailMem(MEMF_LARGEST)
-----------------------------------------------------------
Date : samedi 01-jan-11 09:42:30
Task : 443A6418 "RAM"
Error : 0100000C (Recoverable)
By : ExecLibrary
Cause : Sanity check on memory list failed during AvailMem(MEMF_LARGEST)
-----------------------------------------------------------
Date : samedi 01-jan-11 10:26:20
Task : 443A6418 "RAM"
Error : 0100000C (Recoverable)
By : ExecLibrary
Cause : Sanity check on memory list failed during AvailMem(MEMF_LARGEST)
-----------------------------------------------------------
Date : samedi 01-jan-11 10:52:44
Task : 443A6418 "RAM"
Error : 0100000C (Recoverable)
By : ExecLibrary
Cause : Sanity check on memory list failed during AvailMem(MEMF_LARGEST)
-----------------------------------------------------------


__________________
- A1200+Mediator+VooDoo3+060/50+96mo+IIYAMA 17"+CD,CDRW,ZIP SCSI-KIT
- SAM667EP with MAPOWER KC3000 Case + AOS4.1

Dieser Beitrag wurde von mrodfr am 01.01.2011, 10:59 Uhr editiert.

31.12.2010, 13:17 mrodfr ist offline   Profil von mrodfr Füge mrodfr deiner Freunde-Liste hinzu Email an mrodfr senden AIM Screenname: no YIM Screenname: no
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

kleinen Bug gefunden:

und zwar funktioniert im DefinitionsBrowser der Button "add to code" nicht

26.06.2011, 14:39  
Der_Wanderer
Foren Gott




Dabei seit: März 2006
Herkunft: Karlsruhe, Baden-Württemberg
Beiträge: 3564
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von Der_Wanderer suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Ich werde nochmal drüber fegen und eure Reports berücksichtigen. Danke.


__________________
Check out http://www.hd-rec.de !

27.06.2011, 10:07 Der_Wanderer ist offline   Profil von Der_Wanderer Füge Der_Wanderer deiner Freunde-Liste hinzu Email an Der_Wanderer senden Homepage von Der_Wanderer
Andi
Routinier



Dabei seit: Dezember 2007
Herkunft: Dresden/Sachsen
Beiträge: 255
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von Andi suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

@Wanderer

Viel Erfolg bzw. gutes Gelingen und danke!

29.06.2011, 22:40 Andi ist offline   Profil von Andi Füge Andi deiner Freunde-Liste hinzu Email an Andi senden
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Zitat:

Ich werde nochmal drüber fegen und eure Reports berücksichtigen. Danke.



Was meinen Report anbelangt kannst du das ruhigen Gewissens ignorieren...

Ich bin nun mal selbst "drübergefegt" (also eher mehr geschliddert und gerutscht mit mehr als zwei Besen pro Hand und Fuss ) und habe festgestellt das es gar kein Bug ist.

Man muß den Eintrag den man selektiert hat "nur" per Doppelklick anwählen (was das für einen Sinn haben soll weis ich nicht) dann funktioniert das einfügen tadellos

13.07.2011, 17:05  
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Das Problem das die Syntax in der Titelleiste beim eingeben verschwindet besteht auch noch...

14.07.2011, 07:49  
bernd_
Haudegen



Dabei seit: Oktober 2008
Herkunft:
Beiträge: 561
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von bernd_ suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

>Man muß den Eintrag den man selektiert hat "nur" per >Doppelklick anwählen (was das für einen Sinn haben soll >weis ich nicht) dann funktioniert das einfügen tadellos

hast du mal mit UAE probiert, ob das Problem da auch ist ?
wüsste nicht wieso man dazu doppelklick braucht.bei mir geht es auch so, mit der neuen wizard library, die ich releast habe.die original lib habe ich nicht getestet

Dieser Beitrag wurde von bernd_ am 14.07.2011, 08:54 Uhr editiert.

14.07.2011, 08:54 bernd_ ist offline   Profil von bernd_ Füge bernd_ deiner Freunde-Liste hinzu Email an bernd_ senden
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

@bernd_

Zitat:

hast du mal mit UAE probiert, ob das Problem da auch ist ?



Wie du weist, habe ich kein UAE, weder WinUAE noch sonstein UAE

aber ich werde es auch mal mit deiner Lib testen

Nachtrag:
Bernd, ist die V45.1 vom 15.12.2009 wirklich die aktuellste ?

Nachtrag 2:
Also auch mit der oben genannten Lib aus deinem Stormwizardpacket muß ich einen Doppelklick in das Listview machen damit die Auswahl funktioniert

und wenn ich mir den Loop mal ansehe, dann scheint das auch durchaus gewollt zu sein (?) oder ???

code:


.event_newtype
;  move_cursor{"list2",lst2,-1}
  If RawKeyState($42)  Then Gosub activatesource:ev = 0
  If RawKeyState($45)  Then ev = #IDCMP_CLOSEWINDOW

; swaped the Select functions to remove the undefind situation of the Tableevent if the the window get closed this remove the Hits i had  tomsmart1

  tev.l = WZ_CheckTableEvent{ev}
  If tev = #WZTABLEEVENT_DOUBLECLICK
    Select newtype_mode

Dieser Beitrag wurde von am 14.07.2011, 11:11 Uhr editiert.

14.07.2011, 10:57  
bernd_
Haudegen



Dabei seit: Oktober 2008
Herkunft:
Beiträge: 561
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von bernd_ suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Edit: habe es bei amiblitz 3 getestet mit constant gedrückt.aber irgendwie ging es vorher mal mit single click

da muss man doppelklicken, damit der text unten in der Box erscheint.der text der unten dasteht, wird eingefügt.

bei AB2 ging es mit single click.der text der eingefügt wurde, stand im windowtitle.

Dieser Beitrag wurde von bernd_ am 14.07.2011, 11:17 Uhr editiert.

14.07.2011, 11:07 bernd_ ist offline   Profil von bernd_ Füge bernd_ deiner Freunde-Liste hinzu Email an bernd_ senden
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Zitat:

da muss man doppelklicken, damit der text unten in der Box erscheint.der text der unten dasteht, wird eingefügt.



sag ich doch, und wie aus obigen codeausschnitt ersichtlich wurde das so geändert

14.07.2011, 15:28  
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Gibts denn Aussicht das die gemeldeten Bugs von den Maintainern auch gefixt werden ?

Das die Hilfe im Titel bei eingabe von Text im Source ständig verschwindet ist schon sehr nervig...

Wie bereits in einem anderen Thread beschrieben funktioniert auch der Aufruf der Hilfeguides per Shift/Help nicht mehr bei Includes...

Man möge diese beiden aufgezählten Punkte nicht als meckern sehen, sondern eher als Gedächtnisstütze...

29.10.2011, 13:37  
Der_Wanderer
Foren Gott




Dabei seit: März 2006
Herkunft: Karlsruhe, Baden-Württemberg
Beiträge: 3564
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von Der_Wanderer suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Deine Bugreports wurden erhört ;-)

Schau mal ob es nun besser funktioniert.


__________________
Check out http://www.hd-rec.de !

06.11.2011, 12:14 Der_Wanderer ist offline   Profil von Der_Wanderer Füge Der_Wanderer deiner Freunde-Liste hinzu Email an Der_Wanderer senden Homepage von Der_Wanderer
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

erstmal Danke Thilo...

Nachdem ich den PED kompiliert habe ergibt sich folgendes:

Also die Titelleistenhilfe bleibt nun sichtbar, das ist nun gefixt
Die Hilfe (also die Guide) per Shift/Help wird nicht angezeigt für Includes.

Wenn ich z.B für image_Blit{} die Guide aufrufen möchte wird anstatt eines Guiwindows das die Hilfe enthält der Text "image_Bli" in den Instructionhelper geschrieben....

06.11.2011, 13:44  
Der_Wanderer
Foren Gott




Dabei seit: März 2006
Herkunft: Karlsruhe, Baden-Württemberg
Beiträge: 3564
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von Der_Wanderer suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Ok, habe das auch gefixt.

Sorry, ich muss das nochmal loswerden, damit ich nicht platze: der Amiblitz3 und PED Sourcecode ist " Waaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaahhhhhhhhhhhhhhh hhhhhhhhhhhhhhhhh!"

(und ich meine nicht den Disassemblierten Teil).


__________________
Check out http://www.hd-rec.de !

06.11.2011, 17:09 Der_Wanderer ist offline   Profil von Der_Wanderer Füge Der_Wanderer deiner Freunde-Liste hinzu Email an Der_Wanderer senden Homepage von Der_Wanderer
Gast
unregistrierter Benutzer



Dabei seit:
Herkunft:
Beiträge:
  Antwort mit Zitat Beitrag editieren/löschen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Soderle, habs auch gleich getestet. Beide Bugs sind weg... Dasnke nochmal, das hat echt gewaltig genervt...!

Jetzt noch so ein Tempo bei NTUI und ich bin zufrieden

bin ja schon ruhig



Zitat:

Waaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaahhhhhhhhhhhhhhh hhhhhhhhhhhhhhhhh!"



Jaaaaaaaaaaaaaaaaaaaahaaaaaaaaaaaaaaaaaaaaaaaaaa!
Aber du siehst, man kann auch im wildesten Source der nicht immer macht was er soll eine Lösung finden....
Noch so eine Baustelle wie PFPaint wollte ich mir nicht antun. Sowas nennt man "gewachsene Programme"

Dieser Beitrag wurde von am 06.11.2011, 19:47 Uhr editiert.

06.11.2011, 19:44  
[  «    ...  37  38  39  40  41  ]   « Vorheriges Thema | Nächstes Thema »
Neues Thema erstellen Antwort erstellen
Gehe zu: