Startseite
Amiforce 2.1     Amiforce-News Amiforce-News Amiforce-Forum Amiforce-Forum Amiforce-Chat/IRC-Chat Amiforce-Chat/IRC-Chat Gästebuch Gästebuch Kontakt mit dem Webmaster aufnehmen Kontakt mit dem Webmaster aufnehmen

Amiblitz3
Amiblitz2(alt)
Storm Wizard
Abakus-Design
Helpguide
Toolsguide
Tipps&Tricks
Gamesfun
Links
Download
Musik

Bugfixes am Forum
Subdomains aktiviert
Counterscript entfernt
  Navigation:   Index / 
Amiforce Forum - Amiblitz 3.5 super langsam im Debug Modus
Registrierung Häufig gestellte Fragen Suche Mitgliederliste Moderatoren und Administratoren Startseite Bugtracker Chat Irc
Amiforce Forum » AmiBlitz2/3 (Archiv) » Amiblitz 3.5 super langsam im Debug Modus » Hallo Gast [registrieren|anmelden]
« Vorheriges Thema | Nächstes Thema » Druckvorschau | An Freund senden | Thema zu Favoriten hinzufügen
Neues Thema erstellen Antwort erstellen
Autor
Beitrag
gerograph
Doppel-As



Dabei seit: Mai 2010
Herkunft:
Beiträge: 105
  Amiblitz 3.5 super langsam im Debug ModusAntwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von gerograph suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Hallo,

keine Ahnung ob das so muss, oder relevant ist... das alte Amiblitz 3.5 war wesentlich schneller bei "resize" (image_include) von Bildern im Debug Modus, als das neue Amiblitz (2800 px => 640px längste Seite dauerte früher unter einer Minute, beim neuen Amiblitz warte ich sicherlich 10 Minuten. Allerdings nutze ich die allerneuste image_include.

Meine alte Version:
Build 0.146

Hinterher bei der executeable ist kein Unterschied bei skalieren festellbar... ?


20.10.2011, 16:25 gerograph ist offline   Profil von gerograph Füge gerograph deiner Freunde-Liste hinzu
HelmutH
Moderator




Dabei seit: November 2002
Herkunft: Oberhausen/NRW
Beiträge: 1916
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von HelmutH suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Hallo fleißige Programmierer von AmiBlitz, wo stellt ihr den die neuen Version ab?
Unter der Amiblitz Webseite jedenfalls nicht, da schau ich immer wieder mal rein.
Könnte da mal einer einen Link hier reinstellen?


__________________
Gruß Helmut
Amiga 500, Amiga 2000, AmigaOne

Dieser Beitrag wurde von HelmutH am 22.10.2011, 21:04 Uhr editiert.

20.10.2011, 20:38 HelmutH ist offline   Profil von HelmutH Füge HelmutH deiner Freunde-Liste hinzu Email an HelmutH senden
Der_Wanderer
Foren Gott




Dabei seit: März 2006
Herkunft: Karlsruhe, Baden-Württemberg
Beiträge: 3564
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von Der_Wanderer suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Das liegt daran, dass ich den Debugger in image_Resize angeschaltet habe, als ich Cubic implementiert habe.

Bei CPU intensiven Include Funktionen, die stabil sind, schalte ich oft den Debugger ab, damit das Programm nicht zu langsam wird und der Debugger nur im "User Code" hält, und nicht in der Include.

D.h. du machst nichts falsch. Mit Debugger ist alles in der Regel 10-20 so langsam. Im nächsten Commit mache ich den wieder aus.


__________________
Check out http://www.hd-rec.de !

23.10.2011, 09:20 Der_Wanderer ist offline   Profil von Der_Wanderer Füge Der_Wanderer deiner Freunde-Liste hinzu Email an Der_Wanderer senden Homepage von Der_Wanderer
gerograph
Doppel-As



Dabei seit: Mai 2010
Herkunft:
Beiträge: 105
  Antwort mit Zitat Beitrag editieren/löschen Nach weiteren Beiträgen von gerograph suchen Diesen Beitrag einem Moderator melden        IP Adresse Zum Anfang der Seite springen

Ok. Danke => solved !

26.10.2011, 11:10 gerograph ist offline   Profil von gerograph Füge gerograph deiner Freunde-Liste hinzu
  « Vorheriges Thema | Nächstes Thema »
Neues Thema erstellen Antwort erstellen
Gehe zu: